Aide avec les mosfets à canal P

user2105725

Aide avec les mosfets à canal P


j’essaie de me mettre la tête autour des mosfets du canal p et j’ai acheté des mosfets A03401. Si je comprends bien, le mosfet ne permettra pas au courant de circuler si Vgs == Vds et c’est pourquoi la résistance de rappel est là. Je n’ai même pas encore essayé de connecter un microcontrôleur car la led était allumée dans cette configuration. j’ai lu Vgs et Vds et ils sont tous les deux 0.6v et donc je ne sais pas pourquoi le mosfet permet au courant de circuler. Toute aide serait très appréciée. Merci. ps. appolgies pour mauvaise qualité d’image, l’appareil photo est cassé.

circuit

KingDuken

Il semble que votre source et votre drain soient échangés. Vous parlez d’un appareil PMOS, n’est- ce pas? Rappelez-vous comment le courant circule dans un appareil PMOS et NMOS 🙂

Andy aka

Si vous ne pouvez pas obtenir les bonnes connexions, essayez au moins d’obtenir le numéro de pièce correct (O pas 0).

user2105725

ah oui c’est le problème merci! j’étais toujours dans l’état d’esprit de mosfet canal n, vous devrez me pardonner je suis juste un amateur. Merci pour l’aide. une dernière question. serait-il sûr de passer de 4.2v à un arduino 3.3v en utilisant cette configuration?

Réponses


 Michael Karas

Le P-MOSFET est mal connecté. La borne Source (S) doit être orientée vers le 5V et le Drain (D) doit être connecté à la LED de votre schéma.

La condition dans laquelle le P-MOSFET sera désactivé est si la tension entre la porte (G) et la source (S) est inférieure au V GS THR .

La raison pour laquelle la LED s’est allumée dans votre configuration dessinée est que la diode du corps était polarisée en direct et laissant passer le courant de la borne D à la borne S.

 

#à, aidé, avec, canal?, Les, Mosfets, P

 

google

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *