Besoin d’aide avec la conception de circuits pour la mesure du courant du démarreur de voiture

krb686

Besoin d’aide avec la conception de circuits pour la mesure du courant du démarreur de voiture


D’accord, je veux créer un circuit simple pour mesurer les courants élevés provenant de la batterie de ma voiture, et je pense que j’ai quelque chose qui pourrait fonctionner, mais j’aimerais que quiconque en sache plus me pointe dans la bonne direction.

Je lis que les démarreurs de voiture peuvent tirer des centaines d’amplis, et donc pour des raisons de conception, j’ai simplement supposé que ma voiture atteindrait un maximum de 200 A pendant l’allumage. C’est peut-être plus élevé, mais j’ai une petite voiture (Ford Escort) et je pense que si elle dépasse 200 A pendant un court instant, ce sera correct.

Ma conception consiste à utiliser une résistance shunt pour obtenir une lecture du courant élevé.

Il s’agit d’un shunt à l’échelle 200A, 75mV de Digi-Key, ici .

Je veux donc prendre la tension sur le shunt, l’injecter dans un ampli-op et le mettre à l’échelle au maximum à 5V pour un arduino. Voici ce que j’ai trouvé .

Si vous faites glisser la résistance à fond vers la gauche, la charge (modélisation du démarreur) tombera à 0,06 Ohms, ce que j’estime que le démarreur doit tirer 200 A d’une batterie de 12 V. .06 = 12/200.

Ensuite, si vous le faites glisser vers la droite, il imite le fonctionnement normal, pour une consommation de courant pour le reste de la voiture, et ira jusqu’à 12 ohms, tirant 1 ampère.

Vous pouvez voir la sortie de l’ampli opérationnel à 5 ​​V maximum et la puissance du shunt à environ 15 watts.

Donc, évidemment, cette conception de circuit semble fonctionner en théorie, mais ce que je veux savoir, c’est s’il existe une meilleure façon de le faire? Ou si le circuit peut être amélioré? Ou si cela pouvait même fonctionner?

Réponses


 Andy aka

Votre lien de circuit était bizarre mais je pense que j’ai eu l’idée: –

entrez la description de l'image ici

C’est le plus proche que je puisse trouver et cela fonctionne mais le vôtre ne le sera pas (très précisément) car vous avez mis tout le gain dans votre seul et unique amplificateur (équivalent à A1 avec R2 et R4 à 67kohm et R1 et R3 à 1kohm) . Pensez à ce que sera la sortie en l’absence de courant, c’est-à-dire que les tensions d’entrée sont les mêmes.

Théoriquement, ce sera 0V mais un changement de 1% de la valeur de l’une de ces résistances générera une tension d’erreur importante sur la sortie de l’ampli op qui vous donnera une fausse lecture car le taux de réjection en mode commun de A1 repose totalement sur une résistance parfaite correspondant alors, les imperfections sont multipliées par le gain (= 67)

C’est pourquoi le circuit que j’ai montré fonctionne beaucoup mieux – les erreurs dans l’adaptation du 1er étage seront multipliées par un gain de 0,1111 (environ), c’est-à-dire qu’il y aura des erreurs mineures pour un décalage de 1% dans les résistances.

A2 fait l’amplification principale et est réglé sur un gain de 250. Globalement, le gain est de 27,78 et plus petit que le vôtre, mais le gain de A2 peut être augmenté.

Si vous avez toujours des problèmes en mode commun, il y a ceci: –

entrez la description de l'image ici

Autres produits TI connexes. Je suis également conscient que la technologie linéaire produit un ensemble de moniteurs de courant côté élevé.

krb686

Merci, c’est très instructif car je ne connais pas grand-chose aux amplificateurs. Ainsi, les erreurs sont réduites par l’amplificateur avec un gain <1, puis le 2e amplificateur est responsable de la majorité du gain global et n’est pas affecté par la non-correspondance car ce n’est pas un amplificateur différentiel?

Andy aka

@ krb686 correct et joliment mis.

krb686

Je pense que je suis encore un peu confus. J’ai essayé de construire ça dans un simulateur mais ça a l’air étrange. J’ai construit uniquement le premier amplificateur avec un gain de 0,111, et réglé toutes les résistances pour avoir une erreur de 1% (les rapports sont définis pour maximiser l’erreur) pour voir ce que l’entrée est à A2, et quand je sors la charge, elle se retrouve avec -48mV sur la sortie. C’est toujours bien mieux que mon circuit, qui avait 0,5 V sur la sortie avec une erreur maximisée et des résistances de 1%, mais je ne comprends pas pourquoi c’est -48 mV. Selon la simulation, V- et V + sont tous deux 1,18 V: bit.ly/195qzrq

krb686

Je suppose que les mathématiques fonctionnent comme ça? Je pense que je me trompe en supposant que l’erreur devrait être 600 fois plus petite que dans mon circuit. Je commençais juste à comparer le gain = 67 au gain = 0,111. (67 / 0.111) = 600, mais comme les résistances sont différentes, cela ne se traduit-il pas de cette façon?

krb686

Quoi qu’il en soit, puisque votre amplificateur a une sortie de 48 mV lorsque V- = V + = 1,22, Acm = 0,039. Et puisque Av = 0.11111, alors CMRR = 0.1111 / .039 = 2.85. N’est-ce pas si mal? Et de toute façon, puisque la sortie a 48mV, cela est amplifié par 250 et la sortie finale atteint à peu près le +/- 15V même en mode commun. Y a-t-il quelque chose de stupide que je fais ici?


 Olin Lathrop

Une résistance shunt n’est pas une bonne idée dans ce cas en raison du courant élevé. La résistance dont vous auriez besoin pour maintenir la chute de tension faible et la dissipation raisonnable serait si faible qu’elle deviendrait très peu pratique.

60 mΩ pour 200 A est ridicule, comme même quelques secondes de réflexion vous l’auraient dit. 200 A x 60 mΩ = 12 V, ce qui signifie que toute la tension serait aux bornes de la résistance, sans aucune pour le démarreur même si elle pouvait en quelque sorte tirer 200 A dans ces conditions. De toute évidence, cela ne peut pas fonctionner. Deuxièmement, la dissipation de puissance est hors de portée. 200 A à 60 mΩ dissipe 2,4 kW!

À ce courant, je chercherais un capteur de courant à effet Hall. Ceux-ci détectent le champ magnétique provoqué par le courant.

krb686

Désolé, je pense que cela a été mal rédigé. Si vous regardez le circuit que j’ai relié, je voulais dire que la résistance de 0,06 Ohm modélise le démarreur. Le shunt est de 0,000375 Ohms. Cela aurait également été vérifié en regardant le shunt que j’ai relié … Donc, la puissance atteint 15 watts sur le shunt, et ce n’est que lors de l’allumage. Je suppose que le courant normal sera de 25A? Donc 0,2 watts


 Jeff

Je recommanderais de regarder un capteur à effet Hall Allegro .

Ce capteur a l’amplificateur intégré et la sortie du signal peut se connecter directement à une entrée analogique sur la carte Arduino.

 

#de, #la, #pour, avec, Besoin, circuits, conception, courant, d’aide, démarreur, du, mesure, voiture

 

google

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *