bitcoin-0.9.3 ne se synchronisera pas sur TESTNET bloqué à la hauteur 26859

damienx

bitcoin-0.9.3 ne se synchronisera pas sur TESTNET bloqué à la hauteur 26859


Téléchargé la dernière boule tar tar core bitcoin 0.9.3. Nouvelle installation pour test et développement. Ce fil ne concerne que le TESTNET, je n’ai pas essayé sur le réseau de production. Lors du lancement du bitcoind, tout fonctionne comme prévu jusqu’à ce qu’il atteigne le bloc à 26859 où il cesse d’ajouter des blocs. Rien ne se passe après qu’aucun autre bloc n’est demandé. Après quelques débogages, il semble que le prochain bloc 26860 contienne une transaction qui échoue à la vérification, donc il ne validera pas le bloc. Ces blocs (qui échouent) ont plus de 2 ans, mais je ne m’attendais pas à franchir cet obstacle si tôt dans le match. Quelqu’un peut-il faire la lumière? Est-ce que je fais quelque chose de mal ici? A téléchargé le bitcoin tar à partir du site Web officiel et vérifié la signature.

Tout le monde peut facilement le reproduire sur le réseau testnet. Toute aide appréciée.

Jimmy Song

C’est vraiment tôt. Vous pouvez essayer de supprimer le dernier bloc (fichier blk00xxx.dat) dans .bitcoin / testnet3 / blocks et redémarrer bitcoind?

greatwitenorth

J’ai exactement le même problème. En utilisant Ubuntu 14.04 et la version Bitcoin 90300, la version de protocole 70002 et j’ai défini txindex = 1

Réponses


 greatwitenorth

Je ne sais pas vraiment pourquoi il a échoué à la hauteur 26859, mais je suis passé à 0.9.4 (à partir de 0.9.3) en utilisant:

 apt-get install --only-upgrade bitcoind 

puis j’ai supprimé le dossier testnet3 et lancé bitcoind et maintenant il fonctionne et a dépassé la hauteur 26859.

skaht

Heureux que vous l’ayez fait fonctionner. Il y avait un correctif pas si évident que je devais appliquer pour obtenir la compilation de v0.9.4.

greatwitenorth

Les instructions ci-dessus sont destinées aux personnes utilisant le PPA.


 skaht

Je ne sais pas si je peux vous aider directement. J’ai compilé le code moi-même à partir du site bitcoin / bitcoin de Github.

Bitcoind vient d’être compilé pour OSX 10.9 et 10.10. Notez que les résultats ci-dessous concernent la v0.9.4. Voici les résultats « getinfo » que j’obtiens pour le testNet. (FYSA – a dû appliquer un lien logiciel afin de ne pas avoir à fournir un nom de chemin de fichier complet.)

 Skaht% bitcoin-cli -conf=testNet.conf getinfo { "version" : 90400, "protocolversion" : 70002, "walletversion" : 60000, "balance" : 0.00000000, "blocks" : 322742, "timeoffset" : 0, "connections" : 1, "proxy" : "", "difficulty" : 1.00000000, "testnet" : true, "keypoololdest" : 1423202150, "keypoolsize" : 102, "paytxfee" : 0.00000000, "relayfee" : 0.00001000, "errors" : "" } 

C’est un peu dérangeant de voir que le facteur de difficulté en est un. Cependant, lorsque j’ai émis un RPC « coin » au bfgminer connecté au bitcoind testNet, j’ai reçu un facteur de difficulté valide.

damienx

Oui, le pb a été corrigé dans 0.9.4 et versions ultérieures.

damienx

Je sais pourquoi il a été bloqué, le bloc 26860 a eu une transaction qui n’a pas pu être vérifiée (version 0.9.3), c’est pourquoi il ne synchroniserait jamais le reste des blocs.

Nate Eldredge

Pour la raison pour laquelle la difficulté est apparue comme 1, voir bitcoin.stackexchange.com/questions/18554/… .

 

#à, #la, #pas, 26859, bitcoin-0.9.3, bloque., hauteur, ne, se, sur, synchronisera, testnet

 

yahoo

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *