Capacité parasite dans ma forme d’onde de charge?

ingénieur

Capacité parasite dans ma forme d’onde de charge?


Je viens de prendre cette trace de ma forme Loadwave pour gradateur halogène contrôlé par PWM.

Je me demandais si quelqu’un pouvait identifier la cause des transitoires inférieurs ou supérieurs à zéro volt pour chaque polarité. Autrement dit, pourquoi la forme d’onde semble-t-elle descendre en dessous de zéro (ou au-dessus) lors de la commutation.

Ceci a été pris avec mon oscilloscope USB et la fréquence PWM est de 31,25 kHz

Le circuit composé de deux mosfets qui PWM la puissance d’une ampoule halogène à partir d’un transformateur toroïdal.

Les fils menant à l’ampoule sont assez longs.

Toute indication sur la cause de ce problème serait d’une grande aide! Mon circuitForme d'onde de charge de mon gradateur halogène

PlasmaHH

Nous n’avons aucun schéma et aucune information où exactement cette trace a été mesurée. Nous pouvons faire des hypothèses, mais serait-ce une bonne idée?

ingénieur

Mis à jour avec schéma. Cette trace a été prise à travers la résistance de charge (bublb)

Andy aka

Comment avez-vous connecté précisément l’oscilloscope.

ingénieur

Les sondes de l’oscillioscope étaient connectées au drain du FET supérieur et au côté opposé de la résistance de charge. La sonde était en mode X10 car ma portée USB a atteint son maximum à X1 et semblait couper la sortie.

Réponses


 Matthieu

Ma première supposition serait une détection inductive dans votre sonde de portée.

Essayez de rendre la connexion de boucle GND de votre sonde d’oscilloscope à votre carte plus petite (c’est une question de zone de captation inductive) – gardez-la aussi près que possible du côté de la sonde d’oscilloscope. Essayez également de tordre fermement les fils de l’ampoule s’ils sont, comme vous l’avez dit, assez longs.

J’espère que ce que vous voyez sont des artefacts de mesure et, dans l’affirmative, devraient être réduits avec les techniques décrites.

ingénieur

le clip de masse de ma sonde va sur la piste de masse de ma planche à pain, donc la surface de cette connexion à la terre est en effet plus grande que nécessaire. Est-il possible que cela cause le problème?

Matthieu

Cela semble être le problème. Connectez le clip de mise à la terre de la sonde aussi près que possible du point que vous mesurez.

 

#de, capacité, charge, d’onde?, dans, forme, ma, parasite)

 

google

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *