L’oscilloscope se déclenche de manière inattendue lorsque l’échelle horizontale est grande

Annie

L’oscilloscope se déclenche de manière inattendue lorsque l’échelle horizontale est grande


Lorsque j’ai défini l’axe horizontal sur quelque chose de grand (40 ms / div ou plus) et que j’ai appuyé sur le bouton Unique, la portée se déclenche immédiatement, bien qu’aucun événement de déclenchement ne se soit produit. J’ai essayé ce qui suit:

  • Régler le déclencheur sur quelque chose de ridiculement élevé et mettre à la terre le canal sur lequel il se déclenche, pour vous assurer que le bruit ne le déclenche pas. Il s’est toujours déclenché immédiatement.
  • Régler l’échelle horizontale à 20 ms / div, appuyer sur le bouton Unique, puis augmenter à 40 ms / div. Cela a fonctionné; c’est-à-dire qu’il ne s’est pas déclenché tant que l’événement déclencheur ne s’est pas réellement produit.

J’utilise un Tektronix MSO54, mais je me souviens également d’avoir observé ce phénomène sur une autre portée dans le passé. Cela doit être quelque chose d’évident, mais pour la vie de moi, je ne peux pas comprendre quoi.

Blair Fonville

Ce bus SPI se déclenche-t-il, SS est-il actif ou Flexray? Ou tout simplement un déclenchement sur front analogique?

Annie

Course du moulin. Front descendant.

Réponses


 Blair Fonville

Assurez-vous que votre mode de déclenchement est défini sur Edge et non sur Auto .

Depuis Tek: Comprendre les paramètres verticaux et horizontaux

Un autre contrôle de déclenchement de base que vous devez comprendre est le mode de déclenchement par défaut ou AUTO. En AUTO, l’oscilloscope attend un déclenchement et s’il n’en voit pas, il capture et affiche une forme d’onde même si les conditions de déclenchement ne sont pas remplies.

Sinon, cela me semble être un problème de bug de firmware.

Je recommanderais de vérifier la version de votre micrologiciel et de mettre à jour la dernière version, 1.6.3 , qui a été mise à jour le 15 février 2018.

Les notes de révision contiennent un tas d’éléments qui pourraient être potentiellement responsables.

Annie

Le type de déclencheur est défini sur edge. Le mode de déclenchement a été réglé sur «Normal», ai-je pensé, mais lorsque j’ai vérifié à nouveau, il a été réglé sur «Auto». Cela n’a pas de sens car à des échelles horizontales inférieures, il ne se déclenchait pas. S’il était vraiment en mode Auto, l’échelle de temps n’aurait pas d’importance.

Annie

Cependant, après avoir réglé le mode horizontal sur « Manuel » puis réglé le mode de déclenchement sur « Normal », le problème a maintenant disparu. J’ai rétabli les paramètres tels qu’ils étaient auparavant, et le problème est toujours résolu … donc j’ai tendance à penser que vous avez raison et qu’il y a un problème de firmware. J’utilise le firmware le plus récent. Si ce problème se reproduit, je contacterai Tektronix et je mettrai à jour ici sa réponse. En attendant, j’accepte votre réponse car « Auto » vs « Normal » était bien le problème.

Blair Fonville

@Annie Right, si cela se reproduit, je le signalerais sans aucun doute. Ces bogues sont plus courants qu’on ne le pense. J’ai trouvé un bug dans mon oscilloscope Keysight DSO204a le mois dernier et je l’ai signalé. J’ai trouvé qu’il manquerait un échantillon sur 10 millions (ou plus). Ils ne m’ont pas cru au début mais ils ont finalement concédé et ont pu le reproduire. En dehors de cela, il s’agit en fait d’une grande portée ( keysight.com/en/pdx-x202067-pn-DSOS204A/… ).


 τεκ

Réglez le mode horizontal sur manuel. page 52

Annie

Cela ne semble pas être à l’origine du problème mais peut en faire partie; voir mes réponses à Blair Fonville.

 

#de, déclenché, est, grande, horizontale, inattendue, l’échelle, l’oscilloscope,, lorsque, manière, se

 

google

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *